ВВЕДЕНИЕ

При изучении систем ввода-вывода и интерфейсов необходимо представлять основные принципы построения средств вычислительной техники, которые в основном определяются той элементной базой, на которой строятся компьютеры. С этой точки зрения весь период развития вычислительной техники от первого компьютера до современных вычислительных машин можно разбить на два этапа. Первый – это этап до появления современных интегральных схем и микропроцессоров. Второй – после их появления и начала выпуска персональных компьютеров (ПК).

На первом этапе компьютеры разрабатывались и изготовлялись на своей собственной элементной базе, их устройства (процессор, ОЗУ, устройства управления и т.п.) имели архитектуру и структуру, присущую только данному компьютеру, связь между устройствами и узлами осуществлялась с помощью интерфейсов, используемых только этим типом вычислительной машины. Стандарты применялись, но в основном касались ПУ, а не внутренних устройств. Поэтому машины разных фирм были не совместимы по элементной базе, устройствам и конструктиву. Это относилось как к большим, так и к малым вычислительным машинам. Это машины типа IBM 360 (370) , DEC PDP-11, БЭСМ-1 (2,6), ЕС ЭВМ-1033 (1040, 1060), СМ-1 (2,3,4), «Урал», «Наири» и т.д. Каждый тип компьютера был в определенной степени уникален.

На втором этапе изменился принцип построения вычислительной техники. Она стала основываться на правиле трех «М»: модульность, микропрограммируемость и магистральность. Модуль представляет из себя функционально полное и конструктивно законченное устройство, серийно выпускаемое и программно (микропрограммно) управляемое (настраиваемое). Компьютеры собираются на основе этих модулей с помощью стандартных каналов связи – интерфейсов. В этом случае модули (устройства) выпускают одни фирмы, а изготовляют компьютер – другие. Модули конструктивно и функционально разнообразны, но совместимы по своим интерфейсам. Модули выпускаются в виде микросхем различного типа (МП, память, ChipSet), съемных плат (материнская плата, платы расширения), различных типов ПУ. Функционально они соответствуют тем устройствам, которые реализуют преобразование, хранение и передачу информации: процессор, ОЗУ, схема управления, устройства ввода и вывода и т.п.

На втором этапе существенно возросла роль стандартизации, без которой разработка и выпуск компьютеров стал невозможен.

Роль и значение систем ввода-вывода и интерфейсов в последнее время существенно возросла. Это связано, прежде всего, с быстрым ростом производительности микропроцессоров. Частота их работы имеет значение в сотни мегагерц (Pentium III), увеличивается их разрядность: 32, 64, 128, 256 бита. Растет емкость оперативных запоминающих устройств, достигая сотен мегабайт и гигабайт. Уменьшается время доступа ОЗУ, составляя единицы и доли наносекунд. Увеличивается количество ПУ, подключаемых к компьютеру, растет их скорость работы. Емкость модуля жестких магнитных дисков уже составляет десяток гигабайт. Увеличивается объем графической информации, выводимый на монитор, широко используется 3- мерная графика, «живое видео».

Все это требует соответствующего увеличения скорости передачи информации до сотен мегабайт в секунду и более и такой организации взаимосвязи устройств в вычислительной системе, которая бы исключала потери процессорного времени и равномерно загружала бы работой все устройства компьютера.

Учебное пособие посвящено рассмотрению роли и места систем ввода-вывода и интерфейсов в вычислительных системах, изложению принципов их построения и функционирования. Оно содержит материалы о наиболее широко используемых интерфейсах ISA, PCI, AGP, SCSI,USB, а также компьютерные лабораторные работы, облегчающие и помогающие изучению этих материалов.

Учебное пособие предназначено для студентов, специализирующихся в области вычислительной техники и программирования. Знание интерфейсов позволит разработчику аппаратуры более грамотно подойти к выбору варианта, соответствующего поставленной задаче. Знания материалов этого пособия необходимы системным интеграторам. Без этих знаний они не смогут подобрать требуемый набор устройств и оптимально объединить их в систему. Сведения учебного пособия помогут системным программистам при разработке собственных драйверов ПУ или адаптировать чужие разработки.

В основе учебного пособия лежат курсы лекций «Компьютерные коммуникации и периферия», «Система ввода-вывода и интерфейсы», читаемые студентам дневных и вечерних форм обучения МИФИ, а также материалы книги Гук М. «Интерфейсы ПК»: Справочник – С.-П.: Питер-Ком,1999 и Web-серверов www.ixbt.ru, www.citforum.ru.