Контрольные вопросы

1) Роль и место систем ввода-ввода и интерфейсов в компьютере.

2) Структура и принципы организации взаимосвязи основных блоков компьютерных систем. Роль интерфейсов. Режим ввода-вывода.

3) Основные организации передачи информации в вычислительных системах.

4) Режим ввода-вывода : программный, с прерыванием, с прямым доступом к памяти.

5) Структура и классификация интерфейсов по способам соединения модулей, по способу передачи информации, по режимам обмена данными, топологии внутренних и внешних интерфейсов. Их сравнительная характеристика.

6) Структуры систем ввода-вывода. Их эволюция. Влияние на производительность работы компьютера.

7) Основные функции интерфейсов. Способы организации передачи информации между источником и приемником. Этапы передачи информации. Транзакции. Шины с коммутацией цепей и пакетов.

8) Основные функции интерфейсов. Способы синхронизации при последовательной и параллельной передачи информации.

9) Основные функции интерфейсов. Принципы организации ввода-вывода в режиме прерываний. Селекция и идентификация устройств с наивысшем приоритетом.

10) Реализация протоколов синхронных и асинхронных передач информации при 2-х шинной или 3-х шинной архитектуре внутренних интерфейсов.

11) Протоколы взаимосвязи внутренних и внешних интерфейсов при взаимодействие с периферийными устройствами.

12) Системные интерфейсы. Шина ISA, ее архитектура, основные сигналы шины. Принцип построения протокола чтения-записи.

13) Шина ISA, основные типы циклов шины. Протокол чтения-записи.

14) Шина PCI, ее архитектура, назначение основных сигналов. Транзакция. Оценка скорости передачи данных.

15) Шина PCI. Выполнение транзакции, способы завершения транзакции. Транзакция записи (чтения).

16) Шина PCI, организация арбитрации, задержка доступа.

17) Шина PCI, функция "таймера задержки", оценка времени доступа на шине.

18) Шина AGP, ее архитектура, отличия от шины PCI.

19) Параллельный интерфейс Cetronics. Назначение сигналов, протокол передачи информации, интерфейсы ECP, EPP. Параллельный интерфейс.

20) Последовательный интерфейс RS-232. Основные сигналы, асинхронная и синхронная передача данных.

21) Интерфейс SCSI, архитектура, основные сигналы. Фазы работы шины.

22) Интерфейс SCSI, адресация, принцип управления рабочей шины, команды шины.

23) Шина USB, архитектура, принципы передачи информации, типы передаваемой информации.

24) Шина USB, форматы передаваемой информации, типы пакетов.

25) Таймер, структура принцип работы, управление таймером, режимы работы (0-5).

26) Таймер, управление работой, способы чтения из таймера.

27) Адаптер параллельного интерфейса, структура, управление, режимы работы 0 и 1.