Программа курса

Тема 1. Принципы организации ввода-вывода информации, способы взаимодействия блоков в ЭВМ. Назначение и роль интерфейсов. Программный ввод-вывод информации, ввод-вывод в режиме прерывания и прямого доступа к памяти. Эволюция структур систем ввода-вывода

Тема 2. Реализация основных функций интерфейса. Функция хранения и передачи информации в 2-х шинной и 3-х шинной архитектурах. Способы синхронизации , синхронный и асинхронный протоколы. .

Реализация функций определения приоритетов и идентификации устройств ввода-вывода, вложенные прерывания. Протокол взаимодействия системной шины и периферийных устройств.

Классификация интерфейсов. Системные интерфейсы. Многомагистральная архитектура ЭВМ, принципы повышения производительности, роль интерфейсов.

Тема З. Шина расширения типа ISA . Архитектура, назначение линий интерфейса, типы циклов шины.

Шина ISA. Протокол записи-чтения, прямого доступа к памяти. Особенности интерфейса EISA.

Тема 4. Шина расширения типа PCI. Архитектура, назначение линий интерфейса. Принцип передачи информации. Транзакция. Арбитрация.

Шина PCI. Протокол чтения-записи, способы завершения транзакции. Задержка доступа. Организация автоконфигурации. Интерфейс типа AGP, особенности использования и работа.

Тема 5. Аппаратные средства интерфейсов. Таймер. Структура таймера, способы инициализации и чтения информации. Режимы работы.

Тема 6. Классификация интерфейсов периферийных устройств. Параллельные интерфейсы типа Centronics. EPP и ЕСР порты. Адаптер параллельного интерфейса, принцип работы, режимы работы, протоколы чтения-записи информации. Интерфейс типа SCSI, архитектура назначение линий интерфейса, организация управления.

Тема 7. Последовательные интерфейсы. Интерфейс типа RS-232. Интерфейс USB. Адаптер последовательного интерфейса, принципы приема и передачи информации, синхронный и асинхронный режимы работы.

Тема 8. Классификация периферийных устройств. Обобщенная структурная схема периферийных устройств. Принцип взаимодействия с системным блоком компьютера.

Тема 9. Средства ввода-вывода текстовой, графической, аудио и видео информации. Внешние ЗУ.

Тема 10. Перспективы развития средств ввода-вывода информации. Новый компьютерный интерфейс третьего поколения 3GIO.