Методические указания к изучению учебного курса

Методические указания

Изучение курса осуществляется на основе данного методического пакета и учебно-методического комплекса (УМК), выдаваемого студентам на CD-ROM или считываемого с сервера кафедры.

Теоретическая часть курса изучается по электронному учебному пособию, содержащему основные принципы построения систем ввода-вывода и интерфейсов и описание конкретных интерфейсов шин расширения и периферийных устройств: ISA, PCI, AGP, RS-232C, Centronics, SCSI, USB.

После изучения пособия студенты должны знать основные типы и функции интерфейсов, их архитектуру и структуру, принципы построения протоколов передачи информации по линиям интерфейсов, реализацию режимов программного ввода-вывода, ввода-вывода в режиме прерываний и прямого доступа к памяти, знать преимущества и недостатки параллельных и последовательных интерфейсов, их производительность, способы синхронизации.

Закрепление материала и получение определенных навыков работы с интерфейсами производится с помощью компьютерного лабораторного практикума, содержащего 4 лабораторных работы: шина ISA, шина PCI, таймер, адаптер параллельного интерфейса. Каждая лабораторная работа содержит методическое описание, размещенное в разделе 5 данного методического пакета и исполняемую лабораторную работу, содержащую теорию, порядок выполнения и модель изучаемого интерфейса или соответствующей схемы. Порядок выполнения лабораторной работы содержит контрольные вопросы.

Исполняемые лабораторные работы находятся в УМК, который выдается дополнительно к методическому пакету. В УМК также имеется краткая вводная видеолекция, читаемая профессором Чернышевым Ю. А., а также электронное учебное пособие, методические указания по выполнению лабораторных работ, экзаменационные вопросы и глоссарий.

Курс изучается самостоятельно. Отчетность по курсу осуществляется в период зачетной и экзаменационной сессии в лаборатории кафедры очно путем самостоятельного выполнения в присутствии преподавателя лабораторных работ.