Аннотация к учебному курсу

Аннотация курса

Курс «Компьютерные коммуникации и периферия» предназначен для изучения систем ввода-вывода и периферийных устройств компьютерных систем. В нем излагается материал о месте и роли средств передачи информации, интерфейсов и систем ввода-вывода в компьютере и их влияние на производительность работы компьютерных систем. Рассматриваются вопросы организации процессов передачи информации в компьютере и режимы ввода-вывода. Даются основные принципы построения и функции компьютерных интерфейсов. Изучаются системные интерфейсы, интерфейсы ввода-вывода и интерфейсы периферийных устройств: PCI, ISA, AGP, RS-232, Centronics, SCSI, USB. Изучаются аппаратные средства интерфейсов: таймер, адаптеры последовательных и параллельных интерфейсов. Рассматриваются принципы работы основных и перспективных периферийных устройств: внешних ЗУ, устройств вывода на печать, графических устройств.

Курс содержит лекции и лабораторный практикум. Практикум реализован в виде компьютерных (электронных) лабораторных работ, посвященных изучению шин PCI, ISA, таймера, адаптеров, параллельных и последовательных интерфейсов.

В результате изучения курса студент должен знать структуру систем ввода-вывода, системные шины, шины ввода-вывода (PCI, ISA, AGP), интерфейсы периферийных устройств (RS-232, Centronics, SCSI, USB). Виды и основные принципы построения периферийных устройств.

Должны уметь выбрать нужную конфигурацию устройств компьютера с соответствующими интерфейсами.

Иметь представление о перспективах развития средств передачи информации и ввода-вывода в компьютерных системах.

Курс имеет общий объем в 48 часов. Из них лекции - 32 часа, лабораторный практикум - 16 часов.

Итоговый контроль в виде зачета по лабораторному практикуму и экзамен по курсу лекций. Промежуточный контроль в виде компьютерного контроля в процессе выполнения лабораторных работ.

Автор курса: доктор технических наук, профессор Чернышев Ю. А.