ИНТЕРФЕЙСЫ ПЕРИФЕРИЙНЫХ УСТРОЙСТВ

Шины ввода-вывода взаимодействуют с ПУ не непосредственно, а с помощью внешних интерфейсов (интерфейсов периферийных устройств).

В отличие от шин расширения, шины внешних интерфейсов имеют большую длину и позволяют подключать к системному блоку компьютера ПУ, находящиеся на расстоянии до нескольких метров.

Внешние интерфейсы ПУ можно разделить на две группы: специализированные интерфейсы и универсальные интерфейсы.

Специализированные интерфейсы обслуживают только один тип ПУ. К ним можно отнести: интерфейсы клавиатуры, интерфейс манипуляторов, аудиоинтерфейсы, интерфейсы мониторов, интерфейс игрового адаптера, интерфейс флоппи-дисков.

Универсальные интерфейсы позволяют подключать различные типы ПУ (печать, сканер, графопостроитель, видеокамера и т.д.). К этим интерфейсам относятся: последовательные интерфейсы RS-232c, USB, Fire Wire и др., параллельные интерфейсы Centronics (стандарт IEEE1284), SCSI, ATA и др.

С развитием шин ввода-вывода и совершенствования самих ПУ изменяются и внешние интерфейсы.

Модифицируются старые, появляются новые.

Но эволюция интерфейсов ПУ идет меньшими темпами, чем системных интерфейсов и шин расширения. В таблице 4 приведены характеристики наиболее распространенных универсальных интерфейсов ПУ в их ретроспективе, начиная с интерфейсов, использовавшимися в первых ПК.

Практически не изменился за весь период развития ПК интерфейс RS-232, который появился в 1969г. Это наиболее простой и дешевый интерфейс. Он является дуплексным интерфейсом с последовательной передачей данных в асинхронном и синхронном режимах со скоростью до 115 Кбит/сек и топологией "точка-точка".

Интерфейс RS-232 чаще всего используется для подключения различного типа манипуляторов, для связи двух компьютеров, подключения принтеров и плоттеров, а также электронных ключей (Security Devices), предназначенных для защиты от нелицензированного использования программного обеспечения. Этот интерфейс позволяет эмулировать специальные терминалы (

UT-52, UT-100 и т.д.). Он используется для беспроводных коммуникаций с применением излучателей и приемников инфракрасного диапазона - IR Connection.

Centronics – параллельный, симплексный интерфейс с побайтной передачей данных со скоростью до 150 КБайт/сек, предназначенный для подсоединения механических печатающих устройств, имеющий топологию "точка-точка". Он был разработан фирмой Epson в начале 80-х годов. С появлением новых видов ПУ и повышения их быстродействия произошло развитие Centronics. В 1994 году появился стандарт IEEE1284, где определялось три вида портов. SPP – начальный вариант Centronics. EPP – улучшенный параллельный порт. (Enchanted Parallel Port). ECP – порт с расширенными возможностями (Extended Capability Port). Последние варианты портов повысили быстродействие до 4-х Мбайт/сек, сделали интерфейс полудуплексным, что дало возможность использовать его для других видов ПУ, например, плоттеров, сканеров, видеокамер и т.п., а также использовать режим прямого доступа к памяти.

Наиболее быстродействующим, но и дорогим, является интерфейс SCSI (Small Computer System Interface), который был стандартизирован в 1986г. Этот интерфейс предназначен для подключений ПУ различных классов: жестких дисков, стримеров, CD-ROM, принтеров, сканеров и т.п. Это параллельный полудуплексный интерфейс со шлейфовой топологией соединения ПУ. С момента его появления прошло три его модификации. В 1994 году появились SCSI-2, а 1997 – SCSI-3. Скорость его возросла с 5 до 80 (160) Мбайт/сек, разрядность стала 8,16, (32) бита. 32-х разрядная шина практически не применяется. SCSI сейчас самый быстрый внешний интерфейс.

В последние годы появилась тенденция по созданию последовательных интерфейсов, не уступающих по скорости и количеству подключаемых ПУ SCSI, но имеющий более низкую стоимость.

В 1996г. появился последовательный интерфейс USB (Universal Serial Bus), работающий на скорости до 12 Мбит/сек и позволяющий подключать до 128 ПУ. Шина USB имеет древовидную структуру и требует специальные разветвители – хабы.

В 1995 был принят стандарт IEEE 1394, основанный на шине Fire Wire. В этом интерфейсе нет хабов и возможно подключение до 63 ПУ, скорость обмена 100 - 400 Мбит/сек.

Основные достоинства этого интерфейса по сравнению с USB определяются тем, что Fire Wire ориентирован на интенсивный обмен между любыми подключенными к ней устройствами, а USB – на взаимосвязь ПУ и ПК. Изохронный трафик Fire Wire позволяет передавать "живое видео", высокая скорость обмена позволяет даже на скорости 100 Мбит/сек передавать одновременно два канала видео (30 кадров в секунду), широковещательное качество и стереоаудио сигнал с качеством CD. Возможно использование шины для объединения нескольких ПК и ПУ в локальную сеть. Скорость передачи до 400 Мбит/сек.

В настоящее время интенсивно продвигается на рынок шина USB, как дешевый и универсальный интерфейс для любого типа ПУ. Он постепенно захватывает и область специальных интерфейсов.

Интерфейс АТА (AT Attachment for Disk Driver), разработанный в 1986-1990 годах для подключения накопителей на жестких магнитных дисках к компьютерам IBM PC AT с шиной ISA . С развитием этого интерфейса сфера его использования стала шире, включив другие виды внешних ЗУ. Развитие АТА шло совместно с появлением новых шин расширения, таких как PCI.

В настоящее время существует несколько разновидностей этого интерфейса для подключения устройств IDE (Integrated Device Electronic). Это варианты АТА IDE, E-IDE, АТА-2, Fast АТА-2, АТА-3 и АТА/ АТАPI-4. Наиболее широко распространен интерфейс АТА-2.

Специальные интерфейсы реализуются проще, чем универсальные из-за их узкой специализации, т.к. они ориентированы только на один вид ПУ.

Для подключения клавиатуры используется последовательный синхронный интерфейс, содержащий 2 обязательных сигнала: данных (КВ-DATA) и импульсов синхронизации (KB-Clock). Клавиатура использует прерывание IRQ2. Интерфейс клавиатуры построен на программируемом контроллере i8042, обеспечивающим двунаправленную передачу информации от клавиатуры и к ней.

Интерфейсы манипуляторов зависят от типа устройства. В компьютерах используются три основных вида устройств ввода "мышь"(mouse): Bus Mouse, Serial Mouse, PS/2 Mouse. Ожидается появление мышей с интерфейсом USB.

Bus Mouse применялась в первых ПК, в настоящее время практически не используется.

Serial Mouse – мышь с последовательным интерфейсом подключается через 25- или 9-штырьковый разъем к последовательному порту (COM-порт), имеет встроенный микроконтроллер, который обрабатывает сигналы от координатных датчиков и кнопок. Каждое событие кодируется по интерфейсу RS-232C.

PC/2 Mouse – мышь, появившаяся с компьютерами PS/2. Ее интерфейс и 6-ти штырьковый DIN мини-разъем аналогичен клавиатурному. Контроллер такой мыши входит в контроллер клавиатуры i8042. Для PC/2 Mouse использует прерывание IRQ12.

Для реализации аудиоканалов используются три вида интерфейсов: PC Speaker, цифровой аудиоканал и канал MIDI – устройств (

Musical Instrument Device Interface).

PC Speaker – стандартный однонаправленный канал управления звуком рассчитан на подключение высокоомного малогабаритного динамика. Звук формируется из тонального сигнала от второго канала системного таймера. Роль этого звукового канала сводится к подаче гудков при загрузке, идентификация ошибок во время POST, а также к сопровождению сообщений об ошибках.

Цифровой аудиоканал реализуется с помощью средств работы с аудиосигналом, имеющимся на плате Sound Blaster фирмы Creative Labs. Звуковые карты имеют обычно 16 битную шину ISA, PCI или PC Card. Звуковая карта имеет в своем составе цифровой канал записи-воспроизведения моно- и стереофонических сигналов, микшер, синтезатор и MIDI-порт.

Цифровой интерфейс музыкальных инструментов MIDI является двунаправленным последовательным асинхронным интерфейсом с частотой передачи 31, 25 Кбит/сек. Этот интерфейс, разработанный в 1983 г., стал фактически стандартом для сопряжения с компьютером, синтезаторов, записывающих и воспроизводящих устройств, микшеров, устройств специальных эффектов и другой электромузыкальной техники. В интерфейсе применяется токовая петля10 ма с гальванической развязкой входной цепи. Токовая петля по принципам передачи информации аналогична интерфейсу RS-232C.

Интерфейс видеомониторов между видеоадаптером и монитором может быть как дискретным, так и аналоговым. Для мониторов с высоким разрешением можно использовать только прямую подачу сигналов на входы видеоусилителей базовых цветов – RGB – вход (Red, Green, Blue – красный, зеленый и синий).

Дискретный интерфейс RGBTTL использовал преобразователи цифра-аналог, расположенные в самом мониторе. Это ограничивало качество цветного изображения из-за малого числа кодируемых цветов (до 64-х). Поэтому перешли на аналоговый интерфейс.

Аналоговый интерфейс RGB перенес цифроаналоговые преобразователи сигналов базовых цветов из монитора на графический адаптер. Такой интерфейс с 8 разрядными ЦАП для каждого цвета позволяет выводить 16,7 миллионов цветов (True Color). Этот интерфейс называется RGB Аналог. Кроме передачи изображения по интерфейсу передают информацию, необходимую для автоматизации согласования параметров и режимов монитора и компьютера. Со стороны компьютера имеется специальный дисплейный адаптер, к которому подключается монитор. С его помощью обеспечивается идентификация монитора, необходимая для автоконфигурации и управления энергопотребления монитора.

В настоящее время для передачи управляющей информации используют последовательные интерфейсы I2C (DDC2B) или ACCESS Bus (DDC2AB), которые имеют всего два сигнала данных (DA) и синхронизации (SCL).

Для расширения частотного диапазона, учитывая тенденцию к использованию последовательных шин USB и Fire Wire для подключения монитора, предложен новый тип разъема EVC (Enhanced Video Connector). Кроме обычного аналогового интерфейса RGB и канала управления DDC2 этот разъем имеет контакты для видеовхода, входные и выходные стереоаудиосигналы шин USB и Fire Wire.

В последующих главах пособия будут рассмотрены только универсальные интерфейсы SCSI и USB.