КОМПЬЮТЕРНЫЕ КОММУНИКАЦИИ И ИНТЕРФЕЙСЫ

Интерфейсы, используемые при построении вычислительных систем, весьма разнообразны и различаются между собой по определенным критериям и характеризуются рядом свойств и параметров. В области интерфейсов существует своя терминология, которая задается теми или иными определениями и понятиями, которые с развитием компьютерной техники постоянно трансформируются, что вызывает необходимость рассматривать их в определенной ретроспективе.

Кратко остановимся на некоторых понятиях и определениях.

Канал – среда передачи информации, представляемой в виде определенных сигналов. Канал реализуется с помощью тех или иных средств, зависящих от физической природы сигналов (ток, напряжение, радиосигнал, оптический сигнал и т.п.). Компьютерный интерфейс является каналом передачи информации с помощью электрических сигналов (импульсов и потенциалов).

Линия интерфейса – это электрический проводник (провод, линия печатного монтажа, контакт разъема платы), по которому распространяется электрический сигнал.

Магистраль – это совокупность всех линий интерфейса.

Шина – группа линий интерфейса, соответствующая определенному функциональному назначению (шина данных, шина адреса и т.п.)

В дальнейшем термин «магистраль» стали заменять термином «шина». В свою очередь понятие «шина» стало в определенной мере синонимом термина «интерфейс», хотя понятие шины более узкое, чем общее понятие интерфейса.

В компьютерах, по причинам, изложенным выше, система ввода-вывода строится на основе магистральных и радиальных способов соединения модулей (устройств), оформленных в виде стандартных интерфейсов, называемых соответственно магистральными и радиальными.

По способу передачи информации интерфейсы делятся на параллельные и последовательные. Разряды данных могут передаваться в интерфейсах одновременно, т.е. параллельно. Такие интерфейсы называются параллельными, и они имеют шину данных из стольких линий, сколько разрядов передается одновременно. При передаче данных по одной линии последовательно разряд за разрядом, интерфейс называют последовательным.

Кажется очевидным, что при одной и той же скорости работы линий интерфейса, пропускная способность параллельного интерфейса выше, чем у последовательного. Однако повышение производительности за счет увеличения тактовой частоты передачи и количества линий данных упирается в волновые свойства соединительных кабелей. Задержка сигналов в различных линиях не одинакова, и это особенно сказывается при увеличении длины линий, что требует для надежной передачи данных дополнительных временных и аппаратных затрат, сдерживая этим рост пропускной способности параллельного интерфейса. Кроме того, в параллельных интерфейсах с увеличением числа параллельных линий и их длины труднее реализовать компенсацию помех, наводимых за счет электрического взаимодействия линий между собой.

В последовательных интерфейсах есть свои проблемы повышения производительности, но т.к. в них используется меньшее число линий, повышение пропускной способности канала связи обходится дешевле.

Поэтому важным параметром интерфейсов является допустимое удаление соединяемых устройств. Оно определяется как частотными свойствами, так и помехозащищенностью используемых каналов связи.

Для интерфейса, соединяющего два устройства (модуля), различаются три возможных режима обмена: дуплексный, полудуплексный и симплексный.

Дуплексный режим позволяет по одному каналу связи, но имеющему две группы линий «туда» и «обратно», одновременно передавать информацию в обоих направлениях. Он может быть асимметричным, если пропускная способность в направлении «туда» и «обратно» имеет существенно различающееся значения, или симметричным. Полудуплексный режим позволяет передавать информацию по одним и тем же линиям «туда» и «обратно» поочередно в разные моменты времени, при этом интерфейс имеет средства переключения направлений канала. Симплексный (односторонний) режим предусматривает только одно направление передачи информации (во встречном направлении могут передаваться только вспомогательные сигналы интерфейса).

Все модули внутри системного блока, а это электронные модули (микропроцессор, оперативная память, контроллеры ввода-вывода и т.д.), соединяются между собой с помощью так называемого внутреннего интерфейса, являющегося параллельным и построенного по магистральному способу. Внутренние интерфейсы предназначены для быстрой связи на короткие расстояния. Причем важна не только высокая пропускная способность, но и малое время доступа активного устройства к исполнителю.

ПУ соединяются с системным блоком по радиальным или магистральным интерфейсам, последовательным и параллельным, называемым внешними. Разъем системного блока, предназначенный для подсоединения к нему внешнего интерфейса и соответствующие ему электронные схемы, называют портом ввода-вывода.

Так как через внутренний интерфейс соединяются в систему все модули компьютера, этот интерфейс стали называть системным интерфейсом (системной шиной). Хотя в дальнейшем это понятие несколько изменилось, о чем речь пойдет ниже. Внешние интерфейсы стали называть малыми интерфейсами или интерфейсами периферийных устройств (см. рис. 1.4).

Важным отличительным свойством интерфейсов является топология соединения модулей (устройств) с шиной интерфейса.

Шины внутренних интерфейсов, являясь параллельными и магистральными, размещаются на системной (материнской) плате, а взаимосоединяемые модули являются электронными, изготовленными в виде микросхем или плат расширения (процессор, ОЗУ, ROMBIOS и т.п.), поэтому каждый модуль имеет свое собственное соединение с шиной. Это соединение реализуется разными способами: печатным монтажем, с помощью слотов, сокетов и разъемов. Причем допустимое удаление модулей друг от друга мало и определяется размерами материнской платы.

Слот (Slot) представляет собой щелевой разъем, в который вставляется какая-либо печатная плата. Слот расширения (

Expansion Slot) - это разъем системной шины, куда вставляется плата или карта расширения (Expansion Card).

Платой (картой) расширения называют печатную плату с краевым разъемом, устанавливаемую в слот расширения, платы, обеспечивающие дополнительный интерфейс, называют интерфейсными картами (Interface Card)

Сокет (Socket) –гнездо, в которое устанавливается микросхема.

Внешние интерфейсы ПУ имеют более разнообразную топологию. Для радиальных интерфейсов – это двухточечная топология: порт системного блока – разъем ПУ (шины RS-232,Centronics) или топология типа дерева (шины USB). Двухточечная топология позволяет к порту подключать только одно ПУ. При древовидной топологии основой (корнем) дерева является порт ввода-вывода компьютера, а ПУ могут быть либо конечным устройством, либо новым центром ветвления. Эта топология позволяет подключать множество устройств к одному порту компьютера.

Для магистральных интерфейсов используется шлейфовая топология (шины SCSI). При шлейфовой топологии шина подключается к одному порту компьютера, а от него последовательно проходит по всем ПУ. В ПУ один разъем подключается к предыдущему ПУ (первое – к порту ввода-вывода), а другой разъем шины используется для подключения следующего ПУ, если его нет, то к этому разъему подключается терминатор (согласующая схема). В этом случае, как правило, контроллер внешнего интерфейса размещается в самом ПУ, а шиной SCSI управляет главный контроллер (адаптер), который фактически является каналом ввода-вывода (см. рис. 1.4).