РОЛЬ И МЕСТО СИСТЕМ ВВОДА-ВЫВОДА И ИНТЕРФЕЙСОВ В КОМПЬЮТЕРЕ

Компьютер выполняет три основные функции: преобразование, хранение и передачу информации.

В соответствии с этим компьютер условно делится на три части. Процессор, который предназначен для преобразования информации. Память, выполняющую функцию хранения информации. Процессор и оперативную память обычно называют центральным процессором (ЦПр). Средства передачи информации, которые целесообразно разделить на две части: внутренние – систему ввода-вывода и внешние – периферийные устройства (см. рис. 1.1а).

Такое разделение средств передачи информации позволяет выделить ту часть вычислительной системы, которая реализует процессы передачи данных и в значительной степени определяет производительность работы компьютера, т.е. определяет его качество.

Система ввода-вывода предназначена для обеспечения передачи информации между электронными устройствами при реализации функций преобразования и хранения данных и, главное, для связи этих устройств с периферийными устройствами. Система ввода-вывода реализуется с помощью соответствующих аппаратных и программных средств.

Периферийные устройства (ПУ) предназначены для передачи информации между компьютером и внешним миром (см. рис. 1.1а). Их основное назначение заключается в преобразовании многообразия форм представления информации во внешнем мире в электрические сигналы, воспринимаемые устройствами компьютера и обратного преобразования электронного представления информации в формы понятные объектам внешнего мира. ПУ связываются с центральным процессором посредством системы ввода-вывода.

Часто процессы и устройства ввода-вывода сводят к понятию «периферия», в результате из рассмотрения исчезают вопросы организации взаимосвязи устройств в компьютере и роль этой взаимосвязи при оценке его производительности.

Вопросам организации ввода-вывода информации в вычислительной системе иногда оказывают недостаточное внимание. Это приводит к тому, что при оценке производительности системы часто используют только оценку производительности центрального процессора, а оценкой системы ввода-вывода пренебрегают.

Это противоречит здравому смыслу. Очевидно, одной из наиболее правильных оценок производительности системы является время ответа (время между моментом ввода задания и получения результата), которое учитывает все накладные расходы, связанные с выполнением задания в системе, включая процессы передачи информации, т.е. ввод-вывод.

О важности системы ввода-вывода говорит также и то, что в настоящее время стоимость и производительность компьютеров различного ценового класса от персональных компьютеров до суперкомпьютеров (суперсерверов) определяется в основном организацией систем памяти и ввода-вывода (а также количеством процессоров).

Производительность процессоров растет со скоростью 50-100% в год. Если одновременно не улучшались бы характеристики систем ввода/вы - вода, то очевидно разработка новых систем зашла бы в тупик.

Функции компьютера, описанные выше, реализуются с помощью устройств, которые создаются на базе различных по своему конструктивному выполнению, стандартных, серийно выпускаемых изделий, которые будем для общности рассмотрения называть модулями. Таким образом, модуль – это функционально полное и конструктивно законченное устройство.

Примерами таких модулей могут быть следующие. Интегральные микросхемы (микропроцессоры, микросхемы управления, адаптеры, микросхема памяти и т.п.). Внешние запоминающие устройства (ВЗУ), выпускаемые в виде модулей жестких и гибких магнитных дисков, оптических и магнитооптических дисководов. Модули периферийных устройств (см. рис 1.1б): мониторы, клавиатуры, печатающие устройства, сканеры и т.п. В качестве отдельных модулей используются платы расширения, на которых располагаются специальные микросхемы и разъемы для сопряжения с другими модулями компьютера.

Основой компьютера является плата, на которой расположены МП, память, основная часть устройств системы ввода-вывода, такую плату называют системной или материнской платой.

При изготовлении компьютера модули соединяются между собой с помощью стандартных конструктивных средств. Следует подчеркнуть, что модули по скорости работы очень разнородны, время выполнения ими операций лежит в очень широких пределах – от долей секунды до наносекунд, т.е. меняется на 8 порядков. Если эту скорость измерять временем обработки одного слова, т.е. временем его преобразования, временем доступа к памяти, временем его передачи, временем ввода или вывода, то получим следующие цифры: микропроцессор – от 1 нсек до нескольких наносекунд, ОЗУ – от нескольких до десятков наносекунд, ВЗУ – от сотен наносекунд до сотен микросекунд, Устройства ввода-вывода – от сотен микросекунд до долей секунд.

В процессе работы компьютера идет постоянная передача информации между модулями. И время передачи информации от модуля к модулю существенно влияет на производительность работы компьютера, а иногда определяет ее.

Огромная разница в скоростях работы взаимосоединяемых модулей создает серьезные трудности для систем ввода-вывода и требует выработки определенных оптимальных решений, обеспечивающих минимизацию простоев центрального процессора и полной загрузки работой других устройств при функционировании вычислительной системы.

Конструктивно компьютер, как правило, представляет из себя системный блок, выполненный в виде отдельного корпуса, где располагается системная плата, и нескольких периферийных устройств, подключенных к системному блоку с помощью специальных кабелей и шнуров.

Компоновка компьютера, т.е. соединение всех модулей между собой, производится с учетом выполнения трех главных требований:

  • Обеспечения максимальной производительности работы компьютера в целом при малой стоимости с учетом времени передачи информации.
  • Конструктивной простоты и минимальной стоимости средств взаимосоединений модулей.
  • Возможности подключения максимального числа ПУ и простота изменения конфигурации ПУ в период эксплуатации компьютера.

Рассмотрим, как реализуется взаимосвязь модулей, с учетом вышеперечисленных требований. Имеются три основных способа соединения модулей между собой (см. рис. 1.2): «каждый с каждым», радиальный и магистральный.

При соединении типа «каждый с каждым» взаимосвязь модулей ни чем не ограничена из-за огромного количества линий связи, поэтому легко выполняются требования высокой производительности, но остальные требования реализовать нельзя из-за сложности взаимных соединений. Поэтому этот способ на уровне модулей не используется.

Радиальный – при этом способе имеется главный модуль, с которым связаны все остальные и они могут взаимодействовать между собой только через главный модуль, что также снижает производительность, но меньше чем при магистральном способе. Такой способ соединения эффективен для соединения модулей, которые в основном работают только с главным. Достоинство – простота каналов связи каждого модуля, что позволяет увеличивать их длину на много больше, чем у магистральных. Радиальный способ позволяет к одному разъему подключать всего одно ПУ или, при соответствующей организации канала, несколько ПУ. Этот способ также нашел широкое применение в компьютерах.

Магистральный – это способ, когда все модули взаимодействуют через общую магистраль. Он является наиболее простым по реализации, но снижает производительность, т.к. все модули делят магистраль между собой. К недостатком этого способа можно отнести также и то, что высокоскоростные магистрали все же дороги и могут быть реализованы только при их ограниченной длине. При определенной организации взаимосвязи, магистральный способ позволяет к одному разъему подсоединить несколько ПУ. Этот способ наиболее широко используется в компьютерах.

Взаимосоединение модулей в компьютере, с помощью рассмотренных выше способов, возможно только при определенной унификации этих соединений.

Средства и правила, обеспечивающие взаимосвязь модулей между собой, называются интерфейсом.

Главное требование к интерфейсам – их стандартизация. Только использование стандартных интерфейсов может обеспечить массовый выпуск компьютеров и их эффективное производство и эксплуатацию. Именно интерфейсы определяют те правила, по которым строятся каналы передачи информации между модулями вычислительной системы.

Физически интерфейс реализуется в виде электрических линий для передачи сигналов и набора микросхем, обеспечивающих выполнение основных функций интерфейса.

В интерфейсе стандартизируются следующие параметры:

  • Структура интерфейса, т.е. количество и назначение линий интерфейса.
  • Параметры электрических сигналов в линиях.
  • Протоколы обмена информацией в интерфейсах, циклы (команды) интерфейса, реализуемые в виде временных диаграмм сигналов, зависящих от архитектуры и структуры интерфейса.
  • Конструктивные параметры интерфейса.
  • Таким образом, стандартный интерфейс – это совокупность унифицированных аппаратных, программных и конструктивных средств и правил, необходимых для реализации взаимодействия различных функциональных элементов в автоматических системах сбора и обработки информации.

В пособии в основном рассматриваются структура и протоколы работы интерфейсов.