Лабораторная работа №4. Программируемый адаптер параллельного интерфейса

1.4. Лабораторная работа №4. Программируемый адаптер параллельного интерфейса

Цель лабораторной работы. Лабораторная работа предназначена для изучения принципов построения интерфейсов с параллельной передачей информации на основе программируемой микропроцессорной БИС, для получение навыков программирования способов программной настройки и инициализации подобных микросхем..

Введение. В лабораторной работе рассматривается стандартная микросхема КР580ВВ55, подобная микросхеме Intel 8255. Эта микросхема предназначена для реализации операции параллельного обмена данными в режиме программного ввода-вывода, стробируемого ввода-вывода с квитированием с возможностью использования режима с прерываниями. Микросхема реализует симплексную, полудуплексную и дуплексную передачу информации. Адаптер используется для связи шины расширения компьютера (например, шина ISA) с периферийным устройством.

Адаптер содержит три 8-разрядных регистра А,В и С (РА, РВ, РС), 8-разрядный регистр управляющего слова (РУС) и 8-разрядный буфер шины данных. Он работает в трех режимах 0,1 и 2. Режим 0 – программируемый ввод-вывод. Режим 1 – полудуплексная передача данных в режиме прерываний со стробированием и квитированием. Режим 2 – подобен режиму 1, но с двунаправленной (дуплексной) передачей данных. В Режиме 0 протокол передачи реализуется программно, в Режимах 1 и 2 – аппаратно. В Режимах 1 и 2 регистр С (РС) используется в качестве регистра управления.

В Режиме 0 обмен информацией осуществляют все три регистра РА, РВ и РС.

В Режиме 1 для обмена используются РА и РВ, разряды РС (0-2) и РС (3-7) образуют управляющие регистры соответственно для РА и РС, образуя каналы передачи данных – канал А и канал В.

В Режиме 2 используется только РА, в качестве регистра управления работают разряды РС (3-7).

В Режиме 1 при выполнении операции ввода в адаптер (канал А) строб STB# от периферийного устройства подается на РС4, а флаг готовности IBF на периферийное устройство с РС5, сигнал прерывания с РС3. В канале В соответственно STB# – PC2, IBF – PC1, INT – PC0. При выполнении операции вывода из адаптера (канал А), флаг готовности ОBF# выдается на периферийное устройство с РС7, а сигнал обратной связи АСК# от периферийного устройства на РС6, INT – PC3. В канале В соответственно OBF# – PC1, ACK# - PC2, INT – PC0.

При реализации режима 2 (двунаправленного ввода-вывода) используются те же самые разряды (STB#, IBF, OBF#, INT), что и в Режиме 1.

Связь адаптера с шиной расширения компьютера осуществляется с помощью буфера шины данных (БШД), сигналов записи (WR#), чтения (RD#), выбора кристалла (CS#), сброса (RESET) и адреса А0А1. С периферийным устройством он связан с помощью двунаправленных линий ввода/вывода данных регистров А, В и С.

Регистр А имеет адрес 00, регистр В – 01, регистр С – 10, регистр управляющего слова - 11

Настройка адаптера на нужный режим работы осуществляется с помощью специального 8-разрядного слова управления режимом работы (MS), которое записывается в РУС по адресу 11. Разряд 7 имеет значение «1» – код MS. Разряды 6 и 5 кодируют режим работы канала А (РА), разряд 4 – направление передачи для РА (ввод, вывод), разряд 3 – направление передачи в разрядах (7-4) регистра С. Разряд 2 кодирует режим РВ, разряд 1 – направление передачи РВ, а разряд 0 – направление передачи разрядов (3-0) РС. Управляющее слово МS может настраивать регистры А, В и С на разные, допустимые режимы работы.

Перед началом работы адаптера идет его инициализация путем записи в РУС соответствующего слова режима работы MS.

В адаптере имеется возможность индивидуальной записи в выбранный разряд РС нужного его значения (0 или 1). Запись производится с помощью специального управляющего слова манипуляции битами (BSR) по адресу 11. Разряд 7 имеет значение «0», в разряде «0» записывается устанавливаемое значение выбранного разряда (0 или 1), в разрядах (3-1) номер разряда РС.

Главное меню компьютерной лабораторной работы содержит следующие разделы: введение, правила работы, изучение программной настройки адаптера (выполняется студентом), изучение протоколов обмена данными с периферийным устройством, изучение работы периферийной БИС (выполняется студентом), справочная информация.

Длительность лабораторной работы 2 академических часа.


Методика выполнения лабораторной работы

1.4.1. Методика выполнения лабораторной работы

При выполнении лабораторной работы студент работает с моделью адаптера, структурная схема которого отображается на экране монитора. Структурная схема содержит все регистры адаптера, состояние которых в виде двоичных кодов может наблюдать студент. Структурная схема дает возможность задавать все управляющие и адресные сигналы, необходимые для выполнения тех или иных операций.

Студент выполняет два задания с последующим контролем по каждому из них.

Первое задание выполняется в разделе «изучение программной настройки адаптера». Задание выдается и проверяется компьютером, компьютер фиксирует в специальном окне экрана итог выполнения заданий. В задании задаются режимы работ регистров А,В и С адаптера. Студент должен сформировать управляющее слово, соответствующее этим режимам и ввести его в РУС адаптера.

После правильного выполнения как минимум 3-х заданий студент переходит к контрольным вопросам. Вопросы задает, проверяет и выставляет оценки компьютер. При получении положительной оценки студент переходит в раздел «Изучение работы периферийной БИС», где выполняет второе задание.

Модель адаптера в этом разделе содержит регистры периферийного устройства и управляющие сигналы от этого устройства (STB#, ACK# ). Задание студенту выдает преподаватель. Оно заключается в соответствующей настройке адаптера и организации передачи информации из (в) адаптера в (из) регистра периферийного устройства путем задания активных значений управляющих сигналов (STB#, IBF, OBF#, ACK#), соответствующих заданной операции.

После выполнения задания студент отвечает на контрольные вопросы, которые задает и проверяет компьютер.

По итогам выполнения заданий и ответов на контрольные вопросы преподаватель принимает работу студента.


Индивидуальные задания

1.4.2. Индивидуальные задания

Студент выполняет два задания. Все задания однотипны и различаются исходными данными.

Первое задание, выдает и проверяет компьютер, оно направлено на формирование навыков у студентов по инициализации адаптера. По этому заданию студент должен сформировать управляющее слово и записать его в соответствующий регистр. Пример такого задания: настроить адаптер: Регистр А на режим 2, Регистр В на режим 1, ввод.

Второе задание, выдается и проверяется преподавателем, оно более сложное и позволяет изучить протокол взаимодействия адаптера с периферийным устройством. Пример второго задания: настроить адаптер и произвести вывод кода 10101010 через регистр А в режиме 1 и ввод кода 1111000 через регистр В в режиме 0.


Пример выполнения работы

1.4.3. Пример выполнения работы

Рассмотрим пример выполнения первого задания из раздела 1.4.2. Сначала формируется управляющее слово, оно имеет код 11000110. С помощью сигнала WR# по адресу 11 записываем это слово в регистр управляющего слова. Нажимаем кнопку «выполнение».

Выполнение второго задания (см. раздел 1.4.2.). Сначала формируется управляющее слово, оно имеет вид 10100010. Записывается это слово в регистр управляющего слова. Записываем код 10101010 в регистр буфера шины данных. Устанавливаем флаг OBF=0 в разряде РС7, устанавливаем значение сигнала АСК=0 в периферийном устройстве, устанавливая WR=0 и адрес 00. Нажимаем кнопку «выполнение» и код 10101010 из буфера шины данных должен записаться в регистр периферийного устройства. После этого устанавливаем адрес 01, RD=0. Записываем код 1111000 в регистр периферийного устройства. Нажимаем кнопку «выполнение» и код 1111000 из регистра периферийного устройства записывается в регистр буфера шины данных.


Список контрольных вопросов

1.4.4 Список контрольных вопросов

По первому заданию контрольные вопросы однотипны и различаются их содержанием. Контрольный вопрос задает код управляющего слова и режим работы регистров А, В и С. Нужно определить соответствует ли этот код приведенному режиму работы. Пример: обеспечивает ли код управляющего слова 10101011 настройку адаптера на режим: канал А, режим 1, вывод; канал В, режим 0, ввод; разряды 4,5 регистра С, вывод; разряды 0-3 регистра С, ввод.

По второму заданию вопросы разнообразны и проверяют знания по принципу работы адаптера.

Примеры таких вопросов.

- Какой из портов может работать в режиме 2?

- Какой сигнал должен быть активным при загрузке управляющего слова: WR, RD, OBF, IBF?

- Указать максимальное число разрядов регистра С, через которые можно передать информацию, если регистр А запрограммирован на режим 2.


Практикум по курсу "Системы ввода-вывода и интерфейсы" (Раздел "Интерфейсы")

1. Практикум по курсу "Системы ввода-вывода и интерфейсы" (Раздел "Интерфейсы")

Практикум предназначен для изучения принципов построения, структуры и протоколов работы интерфейсов ввода-вывода и периферийных микросхем, а также получения навыков по реализации протоколов обмена данными в синхронных и асинхронных интерфейсах и программной настройке микропроцессорных БИС.

Практикум содержит четыре лабораторные работы, две из которых посвящены наиболее распространенным шинам расширения PCI и ISA, а две других изучению микросхем таймера и адаптера параллельного интерфейса.

Практикум реализован в виде компьютерных лабораторных работ, каждая из которых содержит соответствующую модель изучаемого объекта, теоретическую часть, задания и контрольные вопросы. Каждая лабораторная работа выполняется индивидуально за персональным компьютером в учебном классе. В каждой лабораторной работе предусмотрена процедура регистрации студента. Без которой невозможен переход к главному меню лабораторной работы.

Главное меню лабораторной работы содержит разделы «Изучение», «Справка» и кнопку «Выход» из лабораторной работы.

Меню раздела «Изучение» имеет теоретические подразделы: введение, сигналы шины, команды шины, и практические – изучение взаимодействий устройств на шине и контрольные вопросы.

Раздел «Справка» содержит справочный и теоретический материал, включающий информацию об архитектуре, назначении сигналов, операциях записи, чтения и арбитрации, времени доступа к шине и т.п.

Компьютер должен поддерживать конфигурацию, соответствующую установке операционной системы Windows 95 или выше.

Каждая лабораторная работа содержит весь материал, необходимый для подготовки и выполнения работы, включая теорию, методику и порядок выполнения, правила работы, контроль полученных знаний и навыков.

Теоретическая часть лабораторных работ может быть использована для изучения соответствующих разделов курса лекций и подготовке к экзаменам.

Продолжительность практикума составляет 8 часов, что соответствует выполнению четырех лабораторных работ.

С лабораторными работами можно ознакомиться в электронном читальном зале библиотеки МИФИ или получить их у преподавателя в виде электронной копии той или иной работы.