Лабораторная работа № 2. Изучение асинхронной шины расширения ISA

1.2. Лабораторная работа № 2. Изучение асинхронной шины расширения ISA

Цель работы. Изучение принципов работы и протоколов асинхронного интерфейса на примере шины ISA (Industrial Standard Architecture), получение навыков построения циклов шины.

Введение. Шина ISA одна из первых и наиболее распространенных шин ввода-вывода. На ее базе строились компьютеры фирмы IBM. С появлением шины PCI интерфейс ISA занял вспомогательное место и в основном используется в персональных компьютерах для сохранения преемственности с ранее выпускаемым аппаратным и программным обеспечением.

Шина ISA имеет 16 разрядов данных и 24 разряда адреса. Скорость работы шины 8-10 МГц. Шина работает как с 8-разрядными, так и с 16-разрядными платами расширения. Типы задатчиков на шине строго определены.

Тип цикла шины определяется: видом задатчика (МП, КПДП, контроллер регенерации, плата расширения), видом ресурса (память, регистры ввода-вывода), направлением передачи (запись, чтение), разрядностью ресурса (8- разрядный, 16-разрядный), длительностью цикла (нормальный. удлиненный, с нулем циклов ожидания).

Компьютерная лабораторная работа содержит следующие разделы: введение, сигналы шины, циклы шины, особенности циклов АТ-шины, особенности шины EISA, взаимодействие устройств, контрольные вопросы, справка.

Весь теоретический материал содержится в соответствующих разделах лабораторной работы и в «Справке».

Продолжительность лабораторной работы 2 академических часа.


Методика выполнения лабораторной работы

1.2.1. Методика выполнения лабораторной работы

Лабораторная работа выполняется индивидуально за персональным компьютером в учебном классе. Для выполнения лабораторной работы студент входит в раздел «Взаимодействия устройств», где выполняет 5 заданий, которые выдаются и проверяются компьютером.

В каждом задании идет моделирование основных циклов шины ISA путем выбора и указания сигналов шины, которые являются активными в данном цикле.

Результаты выполнения заданий оцениваются по 10-бальной шкале и выдаются в соответствующем окне экрана компьютера.

После выполнения заданий студент переходит в раздел «Контрольные вопросы». В этом разделе он отвечает на 5 вопросов, выдаваемых и проверяемых компьютером.

По итогам выполнения заданий и ответов на вопросы преподаватель принимает или не принимает работу студента.


Индивидуальные задания

1.2.2. Индивидуальные задания

Каждое задание содержит определенный цикл шины, задаваемый с помощью параметров, которые определяют тип цикла и те сигналы, которые в нем участвуют.

Примеры моделируемых циклов шины:

- 8-разрядный нормальный цикл чтения памяти;

- 16-разрядный удлиненный цикл записи УВВ;

- прямой доступ из памяти в УВВ, нормальный цикл;

- регенерация памяти, удлиненный цикл.


Пример выполнения работы

1.2.3. Пример выполнения работы

На рис. 1.2. показан экран с выполненным заданием нормального цикла чтения 16-разрядных данных из памяти.

Рис. 1.2.


Список контрольных вопросов

1.2.4. Список контрольных вопросов

Студенту компьютер задает 5 вопросов, проверяет каждый и выдает итоговый результат.

Пример типовых вопросов:

- Имеет ли интерфейс ISA линии подтверждения запросов ПДП?

- Сколько разрядов имеет шина адреса?

- Размер адресного пространства шины ISA?

- Какой тип цикла определяет следующий набор сигналов: I/O CHRDY=0, CS16=0?


Практикум по курсу "Системы ввода-вывода и интерфейсы" (Раздел "Интерфейсы")

1. Практикум по курсу "Системы ввода-вывода и интерфейсы" (Раздел "Интерфейсы")

Практикум предназначен для изучения принципов построения, структуры и протоколов работы интерфейсов ввода-вывода и периферийных микросхем, а также получения навыков по реализации протоколов обмена данными в синхронных и асинхронных интерфейсах и программной настройке микропроцессорных БИС.

Практикум содержит четыре лабораторные работы, две из которых посвящены наиболее распространенным шинам расширения PCI и ISA, а две других изучению микросхем таймера и адаптера параллельного интерфейса.

Практикум реализован в виде компьютерных лабораторных работ, каждая из которых содержит соответствующую модель изучаемого объекта, теоретическую часть, задания и контрольные вопросы. Каждая лабораторная работа выполняется индивидуально за персональным компьютером в учебном классе. В каждой лабораторной работе предусмотрена процедура регистрации студента. Без которой невозможен переход к главному меню лабораторной работы.

Главное меню лабораторной работы содержит разделы «Изучение», «Справка» и кнопку «Выход» из лабораторной работы.

Меню раздела «Изучение» имеет теоретические подразделы: введение, сигналы шины, команды шины, и практические – изучение взаимодействий устройств на шине и контрольные вопросы.

Раздел «Справка» содержит справочный и теоретический материал, включающий информацию об архитектуре, назначении сигналов, операциях записи, чтения и арбитрации, времени доступа к шине и т.п.

Компьютер должен поддерживать конфигурацию, соответствующую установке операционной системы Windows 95 или выше.

Каждая лабораторная работа содержит весь материал, необходимый для подготовки и выполнения работы, включая теорию, методику и порядок выполнения, правила работы, контроль полученных знаний и навыков.

Теоретическая часть лабораторных работ может быть использована для изучения соответствующих разделов курса лекций и подготовке к экзаменам.

Продолжительность практикума составляет 8 часов, что соответствует выполнению четырех лабораторных работ.

С лабораторными работами можно ознакомиться в электронном читальном зале библиотеки МИФИ или получить их у преподавателя в виде электронной копии той или иной работы.