Лабораторная работа № 1. Изучение шины расширения PCI

1.1. Лабораторная работа № 1. Изучение шины расширения PCI

Цель лабораторной работы. Лабораторная работа предназначена для изучения архитектуры, сигналов, команд и основных операций передачи данных шины PCI (Peripheral Component Interconnect) версии 2.0, получения навыков по построению протоколов синхронной шины..

Введение. Шина является одной из самых распространенных и предназначена для реализации операций ввода и вывода информации. Версия 2.0 имеет частоту 33 МГц и разрядность в 32 и 64 бита, версия 2.1 допускает частоту в 66 МГц, что доводит теоретическую скорость передачи до 528 байт/сек. Основные характеристики шины:

- процессорнонезависимая шина, т.к. она взаимодействует с МП через главный мост;

- двухшинная архитектура с возможностью использования нескольких шин PCI;

- основная операция на шине - блочный обмен в виде транзакций;

- PCI - синхронная шина, все переключения по переднему фронту синхроимпульса;

- шина работает с несколькими задатчиками при центральной арбитрации;

- минимизация времени захвата шины с помощью процедуры таймера задержки;

- три адресных пространства: памяти, ввода-вывода, автоконфигурации;

- контроль по четности;

- поддержка автоконфигурации;

- подключение до 6 плат расширения, включая главный мост;

- два вида питания 5,5/3,3 вольта.

Основная единица передаваемых данных – транзакция. Она содержит фазу адреса (1 такт) и несколько фаз данных: минимальная длительность фазы данных – 1 такт.

Длительность фазы данных может увеличиваться за счет тактов ожидания, когда не готовы к приему (передаче) или (и) задатчик или (и) исполнитель.

Продолжительность лабораторной работы - 2 академических часа.


Индивидуальные задания

1.1.2. Индивидуальные задания

Студент должен выполнить три задания разных по тематике.

Первое задание посвящено реализации транзакции записи или чтения с несколькими тактами ожидания, вызываемых как задатчиком, так и исполнителем. Здесь не требуется учет сигналов цикла арбитрации.

Пример такого задания (см. рис. 1.1).

Смоделируйте транзакцию чтения с 3 фазами данных с 1 тактом ожидания от исполнителя на 1-ой фазе данных, 1 тактом ожидания от задатчика на 2-ой фазе данных. Здесь производится нормальное завершение транзакции.

Второе задание регламентирует момент начала простой транзакции с помощью задания такта установки запроса на захват шины и задержки арбитрации. Пример.

Смоделируйте единственную транзакцию записи с 2 фазами данных без тактов ожидания, REQ# устанавливается фронтом 1-го импульса, состояние шины - холостой ход, задержка арбитрации - 2 импульса, задержка исполнителя - 2 импульса.

Третье задание посвящено изучению аварийного завершения транзакции, когда текущая транзакция прерывается задатчиком с большим приоритетом. Пример.

Смоделируйте транзакцию записи с 5 фазами данных без тактов ожидания, GPN# устанавливается 1-м импульсом, сбрасывается фронтом 4-го импульса, сигнал таймера задержки устанавливается на 5-м импульсе.


Методика выполнения лабораторной работы

1.1.1. Методика выполнения лабораторной работы

Выполнение лабораторной работы состоит из трех этапов.

Первый - самостоятельная подготовка к работе путем изучения теоретических материалов: сигналов шины, ее архитектуры, операций на шине, включая транзакции записи и чтения и арбитрацию. Теорию можно изучать по материалам самой лабораторной работы, по ее разделам: введение, архитектура шины PCI, описание сигналов шины, команды шины, разновидности операций на шине, а также по разделу "Справка".

Второй - работа в учебном классе персональных компьютеров при выполнении раздела лабораторной работы "Изучение взаимодействия устройств". В этом разделе необходимо выполнить три задания. Задание выдает компьютер, он и проверяет правильность его выполнения, выдавая необходимую информацию. Задание заключается в формировании на экране компьютера в специальном окне и в заданных координатах временной диаграммы протокола выполнения той или иной транзакции с учетом сигналов арбитрации и ее прерывания задатчиком с большим приоритетом.

При выполнении второго этапа студент может пользоваться материалами, помещенными в лабораторной работе.

Третий этап – контроль знаний, который осуществляется в разделе "Контрольные вопросы". Выдача контрольных вопросов и их проверка осуществляется компьютером.

По результатам выполнения заданий и ответов на контрольные вопросы преподаватель принимает решение о том, зачесть или нет работу студента.


Пример выполнения работы

1.1.3. Пример выполнения работы

На рисунке 1.1 показан экран, где смоделировано первое задание.

В исходном состоянии экран содержит только чистое поле для рисования временной диаграммы, обозначения сигналов шины PCI, импульсы CLK, кнопку управления, поле итоговых результатов и само задание.

Сигналы рисуются последовательно один за другим, при переходе к следующему сигналу, предыдущий должен иметь окончательный вид. Сигналы рисуются в любом порядке. Выбор сигнала производится установкой на нем курсора и нажатием левой кнопкой мыши, при выборе сигнала меняется цвет его поля.

Рис. 1.1.

Сигнал рисуется путем указания курсором момента (точки на поле экрана) переключения сигнала. После указания всех точек переключения, компьютер сам дорисовывает временную диаграмму этого сигнала.


Список контрольных вопросов

1.1.4. Список контрольных вопросов

При контроле знаний, студенту компьютер выдает следующие виды контрольных вопросов.

- Какая скорость передачи данных на PCI при 32 разрядной обработке?

- Для чего нужен таймер задержки?

- С установки какого сигнала начинается транзакция?

- Сколько тактов занимает транзакция чтения при двух фазах данных?

- Какие сигналы определяют начало транзакции?

- На каком импульсе прерывается транзакция, если сигнал #GRN устанавливается на 10-м импульсе, а сигнал таймера задержки на 3-и импульсе?


Практикум по курсу "Системы ввода-вывода и интерфейсы" (Раздел "Интерфейсы")

1. Практикум по курсу "Системы ввода-вывода и интерфейсы" (Раздел "Интерфейсы")

Практикум предназначен для изучения принципов построения, структуры и протоколов работы интерфейсов ввода-вывода и периферийных микросхем, а также получения навыков по реализации протоколов обмена данными в синхронных и асинхронных интерфейсах и программной настройке микропроцессорных БИС.

Практикум содержит четыре лабораторные работы, две из которых посвящены наиболее распространенным шинам расширения PCI и ISA, а две других изучению микросхем таймера и адаптера параллельного интерфейса.

Практикум реализован в виде компьютерных лабораторных работ, каждая из которых содержит соответствующую модель изучаемого объекта, теоретическую часть, задания и контрольные вопросы. Каждая лабораторная работа выполняется индивидуально за персональным компьютером в учебном классе. В каждой лабораторной работе предусмотрена процедура регистрации студента. Без которой невозможен переход к главному меню лабораторной работы.

Главное меню лабораторной работы содержит разделы «Изучение», «Справка» и кнопку «Выход» из лабораторной работы.

Меню раздела «Изучение» имеет теоретические подразделы: введение, сигналы шины, команды шины, и практические – изучение взаимодействий устройств на шине и контрольные вопросы.

Раздел «Справка» содержит справочный и теоретический материал, включающий информацию об архитектуре, назначении сигналов, операциях записи, чтения и арбитрации, времени доступа к шине и т.п.

Компьютер должен поддерживать конфигурацию, соответствующую установке операционной системы Windows 95 или выше.

Каждая лабораторная работа содержит весь материал, необходимый для подготовки и выполнения работы, включая теорию, методику и порядок выполнения, правила работы, контроль полученных знаний и навыков.

Теоретическая часть лабораторных работ может быть использована для изучения соответствующих разделов курса лекций и подготовке к экзаменам.

Продолжительность практикума составляет 8 часов, что соответствует выполнению четырех лабораторных работ.

С лабораторными работами можно ознакомиться в электронном читальном зале библиотеки МИФИ или получить их у преподавателя в виде электронной копии той или иной работы.